Page 2 of 2 First First 12

Thread: How to make Thief 2 run on a modern computer

How to make Thief 2 run on a modern computer

  1. #26
    Join Date
    Jan 2012

    Unhappy Help

    Hi there,

    Im a little new to this whole edit this edit that stuff, im good with computers, i follow the instructions u laid out specifically, but still cant run the thief or thief 2, please can someone literally talk me through this step by step, i know im asking alot but when im physically directed through something i can pick it up fairly quickly, please help me

    many thanks

    p.s ive been at this for the last two hours, and its driving me kookoo, hope i can get helped as i really love these games, and want to complete them before unwrapping my xmas pressie i got off my dad this year which is thief 3

  2. #27
    LarryG (aka goldsla)

  3. #28
    Join Date
    Aug 2012

    won't budge, help

    My problem is that once I go through cmd (-lgntforce approach) it doesn't do anything, neither do autorun/setup from CD folder in Win explorer. I've waited for 2 hours for something to happenand still no improvement

    intel core 2 duo 2.26 GHz
    ATI radeon mobility HD 3430
    3GB RAM
    Win 7 32-bit (tried with 64-bit a while back, no change)

    help pls!

  4. #29
    Hey I'm Sean & I need help getting Thief 2 to run on my HP G60 445DX Notebook.
    Here are my specs:

    1. OS = Windows Vista Home Premium Service Pack 2
    2. Processor = 2.20 Gigahertz AMD Turion Dual-Core RM-75
    3. Video = NVIDIA GeForce 8200M
    4. RAM = 3 GB's
    5. Sound = NVIDIA HDMI Audio / Driver Version

    The installation went fine, but when attempting to load game, it gets stuck on a black screen and I have to force it to shut down. I tried to make the game play using one processor but it denies my request. I tried running DDFix and it tells me my drivers need to be DirectX6 or higher which I thought they were. I bought this game for $3.95 online and the seller directed me here after I asked for help.

    Thanks in advance, I really don't want to return this awesome game back!
    P.S. If I can call someone it would really help speed up the process

  5. #30
    Join Date
    Feb 2003
    Someone released an unofficial patch that should make it run on almost anything - without DDFix or any other external program:

  6. #31
    I greatly appreciate it R Soul, I'm gonna give it a try right now! I'll let you know if it works out or not . . .

  7. #32
    And what do you know, I followed the instructions and within an hour I got it to work finally! Thanks again man, I was close to giving up on this game, thankfully I didn't!

  8. #33
    For anyone who doesn't have the time and patience to go through all the available patches to figure out what the heck to do, I've done that for you and updated my Thief 2 install instructions to a much simpler process than in years gone by:

    Specifically, The $9.99 version available from GOG plus the patch works wonders. Gory details on my site anyway.


  9. #34
    Join Date
    Feb 2000
    Thanks, John. You are absolutely correct. Thanks also for the link to your web site. I have modified the initial post to reflect this information.

    1.19 solves essentially all problems with T2 in one easy installation. It also removes many of the old limitations on number of objects, etc., so FMs can be made larger and more reliable, without video artifacts and crashes. FMs are starting to come out now that require 1.19, so you might as well use it if you are an avid Thief player.

  10. #35
    Okay I used the patches to get T2 running on windows 7, but my old save files that were backed up on a portable hard drive (that were created on the old computer with the older windows) do not work now. I can get into the load save game section from the main menu, but when I try to load a save, it says "Load Failed" does anyone know how to fix this, or are my old saves no good with the new patches. I would hate to have to start all over from scratch

  11. #36
    Join Date
    Feb 2000
    Originally Posted by INS Division 6
    Okay I used the patches to get T2 running on windows 7, but my old save files that were backed up on a portable hard drive (that were created on the old computer with the older windows) do not work
    I am using Windows XP. I haven't tried it in Windows 7. Here is what I know and have verified (with XP) about compatibility of save files, which should be independent of OS.

    I hope that by "patches" you are referring to the patches that result in updating T2 to version 1.19, as described at the top of the first post. If not, then I think you ought to abandon all other patches and go straight to 1.19, or New Dark. This is simple and automatic after you do a clean install T2. The following describes the situation of save files in version 1.19 vs. 1.18.

    If you have a mission that was developed using the original dromed based on T2 version 1.18, a save file from that mission will open using either 1.18 (original patched T2) or 1.19 (New Dark). This is true regardless of which version of T2 you were using when you generated the save file, that is, the 1.19 writes the save file in the original format. If you have a mission that was developed using the 1.19 version of dromed, it cannot be played with 1.18, and its save files, necessarily written using 1.19, will not open using 1.18 because the 1.19 dromed changes the information in the save file. The errors you get in these cases are "unhandled exceptions."

    If your save files were generated using a version of T2 that is older than 1.18 (e.g., originally shipped version of T2), you may be out of luck. I converted to 1.18 in year 2000, and I have loaded OM save files that old with 1.19, no problem.

    I don't think running in Win 7 should change this, but I am not sure because I haven't tried it. Lots of people are using Win 7, and I have not heard about a problem with save files. Search the following site for further information about Win 7 compatibility:

    You may want to start here for discussion of 1.19

    Another thing you might look at is display resolution. Lack of compatibility of resolution can affect the way the game plays or not. Try changing the resolution of your display and also the resolution within T2 1.19 to be the same as what you had before. Once you get it running, you can change it back and it should work.

    This thread is intended only for describing fixes to make T2 run on modern computers, not for user questions on same. If you find a fix to your problem and it is relevant to the subject of this thread, please post it here. I am curious, and others may have the same problem. You should start a new thread for technical discussions of these and other topics, like Win 7.

  12. #37
    Thanks for the help so far, my T2 is the 1.18 upgraded with the patch to make it 1.19. I have tried the resolution and that had no effect. These saves I have were created while using the "door unlock" cheat that required some text mods to the dark.cfg file. Could that have anything to do with the save game files not loading? I have tried to put that unlock cheat back on the new patched (1.19) to see if this is the case, but my computer will not allow me to save the changed dark.cfg file and tells me I need admin approval (didn't have this problem at all when working on the old laptop).

  13. #38
    Join Date
    Feb 2000
    As I said (please read), start a new thread for this discussion. I do not know the answer. Check TTLG.

Page 2 of 2 First First 12