Thread: Kane and Lynch fix?

Kane and Lynch fix?

  1. #1

    Kane and Lynch fix?

    Hi all, long post but maybe worth a read.
    I got K+L from Steam and it just would not run at all, not even a screen. I posted here several times and saw that lots of people were having problems with it. I tried for about a month to fix it but to no avail, resigned to wait for the patch, if it ever turns up.
    Yesterday I bought Puzzle Quest from steam and that also wouldn't even load. I found on the net a post that offered a fix, it seems a file -OpenAL32.dll -may not have installed so I deleted the game and re downloaded and installed it but it still wouldn't work. Eventually a friend came round and tried. He deleted the game from Steam but this leaves a folder with some files remaining. He deleted this folder also. Then we downloaded the game again and reinstalled OpenAL32, it is a file connected with the games sound. Bingo, Puzzle Quest now works so I asked him about K+L. We tried it and I couldn't believe it, it works. All we can think is that the original OpenAL32 file may have been stopping K+L from running as we have done nothing to it other than replace the file in windows\system32.
    Hope this may be of help to somebody.
    Abit IP35Dark Raider:Core 2 Duo 2.66GHz:4Gb OCZ Ram:ATI 5870:xp pro sp2: Understanding Wife.

  2. #2
    Right, been having the "won't load" problem, I get through the usual steam bit of loading a game but then nothing, zilp, zinch, na-da, no error message, no crashing program, just doesn't load anything. Windows 7 64bit, Intel dual core 3ghz, ATI 4850 512mb, Asus Xonar sound card.

    So let me get this straight, you deleted K&L from Steam, then deleted another folder - what was that folder? Then downloaded the game and reinstalled OpenAL, and now it works?

    Doesn't make much sense because the only thing deleting and reinstalling K&L would solve would be a corrupt install, but too many people have been having the problem for that to be viable.

    Where did you get the version of OpenAL32 that you reinstalled from? And what version is it? Because I did a search for it and found two different versions were frequently used on the net. I had the latest version of the two I found (6.14.0357.24) , and tried reinstalling that latest version, but it hasn't helped. I'm wondering if it might require an older version (which you may possibly have installed in reinstalling)...

    The other thing I have just found out is that if you go into the common folder within Steam, and try to launch the game directly from the .exe under the K&L folder (this DOES work for other games just fine as I have just tested it on another 4 games), then I get the error "The program can't start because xlive.dll is missing from your computer. Try reinstalling the program to fix this problem". This is odd because the Games for Windows - Live installer tries to run when I launch the game from Steam (like directx/live installer does each time you first run a game in Steam and it does that "first time setup" thing), but I assumed it succeeded or was already installed.

    EDIT: I just downloaded and installed the latest Games for Windows - Live client from and the game starts fine now, whether or not I will get any of the other hundreds of bugs and crashes everyone else seems to get too from now on is another question entirely lol.

  3. #3


    ok so i took your advice and went into the common folder.

    there i found the folder XLiveRedist, go into that folder and install the files using the .exe.

    the game runs fine once this is done

    cheers, zack