Page 1 of 2 12 LastLast
Results 1 to 25 of 33

Thread: traod -debugkeys (flycheat!)

  1. #1

    traod -debugkeys (flycheat!)

    I found a new command line option for aod. It's called -debugkeys and will enable some keys to do interresting things. To enable it, do this:
    1. Enter the dos prompt and go to your AOD folder.
    2. Type bin\traod -debugkeys

    Some info will appear on top and 2 bars on the left. This enables some keys:
    F1: Toggle window and full screen mode
    F3: View game details (playing sounds, controls, textures).
    F4: Toggle game speed.
    F8: Zoom in on Lara.
    F9: Toggle portals display
    F11: Toggle texture/wireframe mode.
    b: Enable fly mode. To move, use the Jump button and the cursor keys. To return to normal mode, press Action. You can fly through walls. However, if you fly out of a level and then quit fly mode, Lara will fall down forever.

  2. #2
    Join Date
    Sep 2002
    Great! thanks for sharing!!

    did you try the "\bin\traod -selectlevel -debugkeys" option? if you choose the strange 'all items' level (the 2nd one, right?) and if you press F11 so you get wiremodels, you can see where al the items are and where the end is of the level.


    From the netherlands eh,
    if you're interrested, there's a special about the new tomb raider movie on V8 in a few minutes (after the movie 'hackers')

  3. #3

    Thumbs Up

    Flying over Paris is something i always wanted to do

    You can use the other modules (TRAOD_P3, TRAOD_P4) with
    command line options too.You can find which one you normally
    use, by running the game and pressing Ctrl+Alt+Del.

    Thanks TRWad

  4. #4
    I like the window mode. That should have been implimented in the game.

  5. #5
    I couldn't do it... I tried Everything, But always the game crashes when starting it In this F***in' WinXp..........
    DAMN! Do you have Any Ideas?

  6. #6


    How can I do that on my PS2?


  7. #7
    Originally posted by imm0rtalx
    Flying over Paris is something i always wanted to do
    Did you already cross the the river in Parisian Ghetto? There are 2 bridges over it.

  8. #8
    can you give better instructions... i opened up the dos prompt and typed that in but nothing happened

  9. #9

    Try these 2 shortcuts HERE this will be easier.

    hope this helps

    well it seems that you must actually run from the traod folder so use the cd command to get you to the folder. When you start dos from the shortcut in accessories it will start like this;
    C:\Documents and Settings\Name\

    then you type

    **press Enter**

    now your at


    type in

    cd Program Files\Eidos Interactive\TRAOD
    **press Enter**

    now it says
    C:\Program Files\Eidos Interactive\TRAOD>

    type in
    bin\TRAOD -debugkeys
    **press Enter**

    It should load now.
    good luck

    Spaces are important

  10. #10
    Originally posted by TRWad
    Did you already cross the the river in Parisian Ghetto? There are 2 bridges over it.
    I went over one bridge with roadlights on each side if i can recall,
    and then started to have missing textures all over the screen,
    some black spots (where there was geometry before) and Lara
    started to dissappear.The bad thing is, when you get to those
    loading points, you have to start again from the ground.
    But it's still fun!

  11. #11
    thanks man... but after
    "type in

    cd Program Files\Eidos Interactive\TRAOD
    **press Enter** "

    it says
    "Too Many Parameters - Files\Eidos"

  12. #12

    cd "Program Files\Eidos Interactive\TRAOD"

    Legacy of Kain: The Lost Worlds

  13. #13
    Microsoft has some "Powertoys" for the pc that adds to the right click sub menu

    Open Command Window Here
    This PowerToy adds an "Open Command Window Here" context menu option on file system folders, giving you a quick way to open a command window (cmd.exe) pointing at the selected folder.

    You'll be so busy with this fun stuff you will forget all about Lara fling.

  14. #14
    i tried all that, and got into the right folder (\bin) and tried all 3 program versions but said that a non-existant file (that isn't needed for running it normally) is needed in a folder that has never been created EVER. the error came up in the grey box, (that one with the HANDLE error) after the game tried to run. ive got the update, so could it be that that is stoppiung me from using it?

  15. #15
    Do not go into the 'bin' folder.Instead goto your TRAOD folder
    and execute : "bin\traod -debugkeys" from there.

  16. #16
    oh, right. thanks

  17. #17
    OK, for those that are "afraid" of the command promt

    Right Click on your desktop -->New-->Shortcut.
    Click "Browse", and goto wherever you have installed AOD.
    There's a folder named "bin" and inside a file named "TRAOD.exe".Click on it and press OK.
    Now click "Next", type a name for it (eg FlyCheat) and then "Finish".
    There should be a new shortcut on your desktop.
    Right Click on it and select Properties.
    Click on the 'Target' field and add this line after TRAOD.exe : " -debugkeys" (the space is important)
    Click on the 'Start In' field and delete the "\bin" part.Click OK and you're ready.

  18. #18
    i ran the command prompt from the aod folder but it says

    'bin\traod-debugkeys' is not recognized as an internal or external command, operable program or batchfile

  19. #19
    trfreak5243, insert a space after "traod".
    It should look like this "bin\traod -debugkeys"

  20. #20
    Join Date
    May 2003
    i get the debug thing working and all the F keys work (wire frames,etc..) but i cannot fly.. is there a certain level you are supposed to go to?

  21. #21
    nope ? Just press 'b' and move around like you are swimming...

  22. #22
    This cheat is great Thanks to all who made it possible


  23. #23
    how do you open dos prompt?

  24. #24
    I get this
    Build Jul 2 2003 17:30:55

    The Following Error has occured

    Generic Game Error

    ASSERTION: 'pData && length>0' at C:\projects\tomb raider\Game\ai\script_mgr.c(400)

  25. #25
    well I'm not allowed to because I could stuff up the computer

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts