Results 1 to 2 of 2

Thread: HELP!! (Lara won't dive)

  1. #1
    Join Date
    Jan 2018

    Exclamation HELP!! (Lara won't dive)

    I am having trouble with the Geotherm Valley's High Diving challenge. (With Rise of the Tomb Raider)

    I have pressed LT whenever I jump off of the red wooden platforms but she wont dive. I have been able to get her to dive before but i am no longer able to. I also know it is not my controller because the LT button works when i aim my weapons.

    Someone please help i have tried to reach customer support but they say they cant help me because they are unable to provide game hints or tricks....which i find stupid because i am 99% complete with the whole game and this is the only thing i need to do/accomplish to finish. PLEASE HEEEELLLLPP

  2. #2
    Join Date
    Mar 2008
    Try stepping back on a platform before diving instead of trying to dive off the end of a platform. This worked for me on the PC version.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts