Page 4 of 4 FirstFirst 1234
Results 76 to 80 of 80

Thread: [Xbox one] Mission "Gulag Recon" won't complete. [Under Investigation]

  1. #76
    Join Date
    Apr 2017

    Exclamation This issue is still not fixed and is valid

    Edition: [Xbox One X][Digital] Rise of the Tomb Raider: 20 Year Celebration

    The bug is still present. I can't turn in the mission. Tried to uninstall all the DLCs - same problem remains.
    Please fix this issue...

  2. #77
    Still having issues with this bug. Uninstalling/reinstalling the game on the Xbox does not clear it.

    Very frustrating, as this is keeping me from completing 2 Achievements. The mission has been complete, but the quest giver does not respond to the TALK command.

  3. #78
    WOW! 2018 and u guys haven't fixed this glitch? Jesus... will there be any glitches like this at the Shadow of the Tomb Raider too? Won't be buying it until this gulag mission is fixed........

  4. #79
    This glitch is STILL broken.

    SQUARE... anything???

    This is destroying 2 completion achievements.

  5. #80
    Join Date
    Nov 2018
    I just ran through this. I'm 74% complete in the game. I have digital copy - 30.5GB install, and the 20 Year Celebration Pack, Baba Yaga, and a number more add-ons from a sale on the Microsoft Store this past summer.

    I've tried uninstalling & reinstalling. While the reinstall was happening, I tried numerous times to start the game, as suggested above by MIZDOVE. No luck. Tomb Raider won't let me load my save point until I have 100% of the base game installed (30.5GB).

    I've gone back to each of the locations for the intelligence to make sure I got them and triggered anything that could have happened. I did run across some people and fought/killed them, although this did nothing to advance the game.

    The Challenge Mission is green and is prompting me to return to the Scout to return the intelligence. Any help here would be great!

Page 4 of 4 FirstFirst 1234

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts