Results 1 to 8 of 8

Thread: PS4 challenges bug

  1. #1

    PS4 challenges bug

    Until the update I was fine, I completed every challenge except 2 and was 2 away from getting my Final Gold Trophy. The game updated and I lost half my saved data. Still I was far along so decided to go back and replay the challenges to get the final trophy only to find out that they are all messed up.. I already got the 5 Red Skulls in all the tombs and can not get them again, (because they are not there) and still showing that is challenge I need to complete. I also got over 100,000 in the tomb of the tortured, and it even says she nI hit the 100,000 "gold point challenge complete" but still at the end is showing it is not. (see screen shot of me with 104,000 points and still no Gold point challenge. This save issue messed up a lot more stuff and now I feel like the only way this might work is if I delete the entire save file and start completely over. Which is ridiculous. I also saw thread that I can delete the game, and delete the update file and it will work, well it does show that I have the 5 red skulls but all the Gold point challenges are still messed up. In all the Tomb, above the Bronze point challenge, it says nothing but 0/1 next to it, that use to mean if you complete the tomb one time it would show 1/1. now even after completion it shows 0/1. whatever you guys did to fix the save data problem has cause a lot of more problems and the new save file is not recognizing any of the stuff we completed , but even worse, if we do it over again, it still shows not complete.. This is a box problem.. Please advise!! ? Notice ins screen shot after completing tomb with gold point score, still showing not, and also notice the gold point score is 10,000 instead of 100,000. also notice under the score it shows 0/1 instead of 1/1 even after completing the challenge.

  2. #2
    Sadly I had this issue too.
    I already got the gold trophy for the game (completing every challenge) before the game officially launched (my store sold it like a week early, don't know why)
    But I think after the second patch, all my challenges got messed up, and it has been so since.
    I hope they fix it, but eitherway, I got all the items and the gold trophy as proof anyway.
    Just a little annoyance,

  3. #3
    Reinstalling the game did not work for me with this glitch. I started a "new game" and was able to keep all of the weapon unlocks (including ones from challenges the glitch made incomplete) and amulet and ring unlocks. So with the new unlocks I've been proceeding along nicely trying to get all challenges.

    I think the difficulty is Tomb of the Torturer. On second time through upon completing that all of my overworld challenges were blanked until after I faced the Pharoh where there were no challenges (oddly?) So I've been going back to the other stuff excluding what I haven't completed in Tomb of the Torturer. Tomb of The Torturer was also the last tomb I'd been in prior to the patch. Thought I'd leave that mess for last and to give more time to sort this out.

  4. #4
    I'm glad you got he trophy because this is driving me nuts! I can't believe I gotta go through the game again, thankfully its short.

  5. #5
    Thanks for the reply, so did you start a new game keeping the old save data and starting off that or did you delete he save data?? I'm scared if I load off the old data and start a new game , just to keep all the weapons that It might still cause a glitch.. Have you been able to complete the challenges now that you started a new game? Even the tomb of the torturre? And when you started a new game did it fix the "gold point challenges in the tombs" issue that was Showing the gold point challenge to be 10,000 instead of 100,000?

  6. #6
    I tried the re-install and using my last save pre-patch and that didn't solve it. So I just went "heck with it I'm still having fun with this despite this glitch" and started the new game. So far in my "new game" (second playthrough which should maybe be called "new game plus" since you keep all your unlocks but otherwise get a blank slate) everything has worked "properly" as far as I can tell.

    Are there challenges for the confrontation with Pharoh? (The boss on the "cold spewing" battlefield.) If there are that is a bit of a problem because it didn't show any on my second play through which I noted above.

  7. #7
    Well I started completely over like you said and I kept all my weapons and rings emulets and so far so good, I just completed 2 challenge tombs and they are updating and saving properly, the gold points rewards is correct, now saying 100,000 instead of 10,000 .. Sucks that this had to happen but I'm going to continue the okay through. If they have another update that ruins the game and or save progress again though I will be requesting a refund

  8. #8
    My PS4 copy is all screwed up as well now with the challenges. Most of them say they are not completed when in fact they are and I cannot redo them. I haven't tried a new game and shouldn't have to as I don't want to redo all the challenges that I've previously completed.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts