Thread: Thief, Crash when trying to use Mantle

Thief, Crash when trying to use Mantle

  1. #1

    Thief, Crash when trying to use Mantle

    On my particular PC using a AMD Athlon X4 860K and AMD Radeon HD 7850, I can't run Thief in Mantle mode. When I check Mantle and proceed to start/play the game it crashes before the intro videos even come up.

    I am using AMD Catalyst 14.9 or the lastest non beta drivers and the computer recently had a fresh OS Install in which the drivers and software were installed newly. The game is updated to whatever is latest and is on 1.7. I was hoping I could get a little more FPS through Mantle but as it's not working I'm not sure what to do.

  2. #2
    Try setting Depth of Field to high in the launcher, if it isn't set to that already, then try launching the game. I had exactly the same crash with Mantle and it turned out to be the DOF setting. Personally I'd prefer to run the game with DOF set at normal, but the game will crash if it is.

  3. #3
    Originally Posted by Gothik
    Try setting Depth of Field to high in the launcher, if it isn't set to that already, then try launching the game. I had exactly the same crash with Mantle and it turned out to be the DOF setting. Personally I'd prefer to run the game with DOF set at normal, but the game will crash if it is.
    Thanks for your reply. I will try your suggestion once I get home and see if it works.

    .:edit:.

    Did as you told me and I can play in Mantle mode now. Computer use to struggle to average 30FPS on the lower settings. Now I can max out everything except SSAO and FXAA and average 50ish FPS

  4. #4
    Yeah, Mantle works really well in that respect - I get great FPS with it too. I would like to turn DOF down though...