Thread: Fatal Error: Failed to initialize Direct3D.

Fatal Error: Failed to initialize Direct3D.

  1. #1

    Fatal Error: Failed to initialize Direct3D.

    That's the error I get when I try to run Thief. All my drivers are up to date. Minimum specs have been met. An online system checker says I should be able to run it but when I do, I get a pop-up with "Fatal Error: Failed to initialize Direct3D."

    System is as follows:
    MB = Asus Sabertooth 990FX R2.0
    CPU = AMD FX-9370
    Vid Card = Asus nVidia GeForce GTX 750 Ti
    RAM = 32G Corsair Vengeance
    OS = Vista SP2

    Any help would be much appreciated!!

  2. #2
    Oh yes, and in accordance with this thread: http://forums.eidosgames.com/showthread.php?t=141619

    19:44:27:754 (3460) > THIEF (32-bit)
    19:44:27:754 (3460) > ==============
    19:44:27:754 (3460) >
    19:44:27:770 (3460) >
    19:44:27:770 (3460) > Memory statistics:
    19:44:27:770 (3460) > Total RAM = 31.8 GB (32600 MB)
    19:44:27:770 (3460) > Avail RAM = 29.1 GB (29817 MB)
    19:44:27:770 (3460) > Total virtual memory = 4.0 GB (4095 MB)
    19:44:27:786 (3460) > Avail virtual memory = 3.8 GB (3876 MB)
    19:44:27:786 (3460) > OS = Windows Vista (build 6002)
    19:44:27:801 (3460) > [Main] Version: 1.6 build 4158.14
    19:44:27:801 (3460) > [Main] Command line:
    19:44:27:801 (3460) > [Main] Base directory: E:\Install\Steam\steamapps\common\Thief\Binaries2\Win32\
    19:44:27:864 (3460) > [Platform] CPU Page size=4096, Processors=8
    19:44:27:864 (3460) > [Platform] High frequency timer resolution =14.318180 MHz
    19:44:27:864 (3460) > [CPUCount] -----------------------------------------
    19:44:27:865 (3460) > [CPUCount] GetLogicalProcessorInformation results:
    19:44:27:865 (3460) > [CPUCount] -----------------------------------------
    19:44:27:865 (3460) > [CPUCount] Number of NUMA nodes: 1
    19:44:27:868 (3460) > [CPUCount] Number of physical processor packages: 1
    19:44:27:873 (3460) > [CPUCount] Number of processor cores: 8
    19:44:27:878 (3460) > [CPUCount] Number of logical processors: 8
    19:44:27:883 (3460) > [CPUCount] Number of processor L1/L2/L3 caches: 16/8/0

    19:44:28:071 (3460) > [Render] NxApp PreInit
    19:44:28:080 (3460) > [Render] Enumerating adapters:
    19:44:28:085 (3460) > [Render] Adapter 0:
    19:44:28:091 (3460) > Description : NVIDIA GeForce GTX 750 Ti
    19:44:28:096 (3460) > Vendor : nVidia (10de)
    19:44:28:101 (3460) > Device : 1380
    19:44:28:107 (3460) > Sub system : 84bb1043
    19:44:28:112 (3460) > Revision : 162
    19:44:28:117 (3460) > Dedicated Video Memory : 1974 MB
    19:44:28:122 (3460) > Dedicated System Memory : 0000 MB
    19:44:28:127 (3460) > Shared System Memory : 2048 MB
    19:44:28:133 (3460) >
    19:44:28:138 (3460) > [Render] Loading NVAPI...
    19:44:28:150 (3460) > [Render] NVidia 3D Vision NvAPI_Stereo_IsEnabled error.
    19:44:28:155 (3460) > [Render] Done loading NVAPI
    19:44:28:161 (3460) > [Render] Enumerating monitors:
    19:44:28:166 (3460) > [Render] Monitor 0: handle = 0000000000010001, aspect = 1.78
    19:44:28:170 (3460) > [Render] Monitor 1: handle = 0000000000010003, aspect = 1.78
    19:44:28:175 (3460) >
    19:44:28:181 (3460) > [Render] Failed to load d3d11.dll
    19:44:28:187 (3460) > [Render] Mantlexx.dll not found! (Config Dialog)
    19:44:28:191 (3460) > [Render] MantleAxlxx.dll not found! (Config Dialog)
    19:44:28:196 (3460) > [Render] Mantle dlls NOT found. (Config Dialog)
    19:44:28:200 (3460) > [Render] Failed to initialize Direct3D.


    Which is strange because supposedly my DirectX is up to date. I even ran that file mentioned in the above thread (\Steam\steamapps\common\Thief\_CommonRedist\DirectX\Jun2010, run DXSetup.exe)
    So I'm stumped.