Thread: Unable to select TrueAudio

Unable to select TrueAudio

  1. #1
    Join Date
    May 2006
    Posts
    6

    *Solved* Unable to select TrueAudio

    Hi,

    Just bought this game so far I'm loving it except I can't select TrueAudio in game menu as it is not available as an option.

    My Rig:

    CPU: Intel i7 4770k @4.2Ghz @1.2v
    Mobo: Asus Z87-A
    RAM: 2 x 4GB
    GPU: Sapphire Tri-x OC UEFI Edition 290x
    CCC version: 14.8 WHQL (Also tested with 14.7 RC3) p.s. Clean install on each driver by using DDU
    Soundcard: Creative X-Fi Titanium
    OS: Windows 7 64bit up-to-date
    Game mode: Mantle

    I've already selected stereo speaker in control panel and is matching with the in game setting. And also disabled all those creative effect like EAX, 3D CMSS etc.

    So is there anything I missed or doing wrong?

    Can anyone help to look at this issue?

    Thanks in advance!

  2. #2
    Join Date
    Dec 2007
    Location
    The highest ground...
    Posts
    23,047
    Afaik, the third patch dealt with AMD Mantle and TrueAudio support - as per this post:

    http://forums.eidosgames.com/showthread.php?t=142398

    The entire thread may be of use to you. Good luck.
    signature image
    You are only minimally modified. Omar can help you correct this...

  3. #3
    Join Date
    May 2006
    Posts
    6
    Hi Viktoria thanks for the link!!!

    I bought the game just a day ago on steam so it's the most updated one which is 1.6, and no the TrueAudio isn't available in the game setting menu.

    What I've done so far is disabled all those creative services and effects, uninstall /reinstall the game clean install / uninstall driver for 14.7RC3 and 14.8, none of them works.

    I'm wondering if it is the game problem or the driver problem.

    on steam forum someone also having the same problem as me but he's using 14.4 and claiming that sometimes it works sometime not, seriously I'm scratching my head and wondering what's wrong with the Trueaudio.

    I've also reported the bug to AMD as well and will see how it goes.

    Anyway, thanks again!!!

  4. #4
    Join Date
    May 2006
    Posts
    6
    Hi,

    Finally I managed to fix the problem!!!! In a way it is the driver problem but kind of minor but annoying way.

    Ok here is the FIX:

    1) Make sure you installed the ACP user service during the driver installation
    2) After installed type services.msc on run under start menu
    3) Make sure ACP user service is enabled ---> this is the trueaudio driver / service and most likely show you an error when you manually start
    4) If that's the case go to and run C:\AMD\CURRENT-DRIVER-VERSION\Packages\Apps\ACP64\ACP64.msi
    5) Go back services.msc and see if it starts or not if isn't start it manually

    6) Voila!!! Trueaudio is enabled and I'm loving it!!!

    Thanks!!!