Thread: Thief has no sound or subtitles, but the background sound works fine

Thief has no sound or subtitles, but the background sound works fine

  1. #1

    Unhappy Thief has no sound or subtitles, but the background sound works fine

    i have had thief for almost 3 weeks and can't use it, the audio for voices and also the SUBTITLES do not work at all. although the background does work fine i am giving you this link https://www.youtube.com/watch?v=hYiOR0oHjJg it is my video i posted for this issue so you can see what is wrong since the support staff can't fix this issue, and directed me to you guys. since half the issue is that subtitles don't work as well and i have given a DXDiag file and they saw i had every thing updated they don't know what to do. i need you to help me with this.

  2. #2
    Join Date
    Mar 2014
    Posts
    55

    Look Below...

    Just below your thread is a thread all about the MANY audio issues that STILL need to be fixed. Feel free to ask to our list there and pray that these developers ARE working on a patch.

  3. #3
    Join Date
    Dec 2012
    Posts
    17

    Please help me!

    Originally Posted by dravenhaven
    i have had thief for almost 3 weeks and can't use it, the audio for voices and also the SUBTITLES do not work at all. although the background does work fine i am giving you this link https://www.youtube.com/watch?v=hYiOR0oHjJg it is my video i posted for this issue so you can see what is wrong since the support staff can't fix this issue, and directed me to you guys. since half the issue is that subtitles don't work as well and i have given a DXDiag file and they saw i had every thing updated they don't know what to do. i need you to help me with this.
    Hi,

    Have you tried verifying your game via Steam? Silly I know.
    Tried reinstalling it?

    I can play the game no problems but when I go to load a Saved game or hit "Continue" or try to load an Auto Save point I get a CTD.

    Can you help me with this?
    Thanks,
    Stefos

  4. #4
    i have reinstalled over 7 times and have also verified as well.