Hey guys,

So I bought Thief 4( The newest one) on steam a few months ago and after all the research I've done I cant find a way to get it working. Every time I click play in steam it pops up a window with the following:

"Thief has stopped working"

As soon as I click the "Play" button this pops up. I never even see anything open.

Here is the crash:
Problem signature:
Problem Event Name: APPCRASH
Application Name: Shipping-ThiefGame.exe
Application Version:
Application Timestamp: 533be960
Fault Module Name: StackHash_254c
Fault Module Version: 6.1.7601.18247
Fault Module Timestamp: 521ea8e7
Exception Code: c0000374
Exception Offset: 000ce753
OS Version: 6.1.7601.
Locale ID: 1033
Additional Information 1: 254c
Additional Information 2: 254c3cd18eb8ede7ee02d4debd373523
Additional Information 3: 0660
Additional Information 4: 0660ccb4249931fdcfe91cb3363d3417

So I've tried the whole moving the win32 into win64 and all that and nothing happened.

I've tried turning off my crossfire but that didnt help either..

Here are my specs:

Mobo: ASROCK Extreme3 Gen3
GPU'(s) - (2) AMD Radeon HD 6950's in crossfire
RAM - 16GB Corsair
CPU - Intel Core i5 2500k overclocked @ 4.5GHz

Any help would be appreciated!