Results 1 to 7 of 7

Thread: Soul Reaver 1 Controller Issues on Steam

  1. #1

    Soul Reaver 1 Controller Issues on Steam

    Okay So i bought all the legacy of kain games on steam when they were on sale as a bundle. But found out to my dismay that the first game Soul reaver gamepad controls were absolutely horribly done. What I mean by this is that I can't actually play the game with a controller, even though its a in-game option, because my character is stuck in auto run and runs to the right. Also when I go into the menus it will only allow me to select the top or bottom option on the list. Yes I know I can play it with the pc controls but I know me and many other people on steam are upset about this because they want to play it like they did in their childhood.

    Also I did take a look at the steam forums for this game. People have found a way around this. The way they found was to buy the xpadder program and then download a custom button scheme map for the game. Or to download another free controller program, but it isn't able to work to the full extent.

    I went through steam to ask them to fix the problem. They told me to talk to the people who made the game, sqaure enix. Square enix told me they don't support this game anymore and to come here.

    So i was wondering if anyone could point me in the correct direction to get this game's controller program fixed on steam, because I don't think it's right that I have to pay for a program to play this game on a controller?

  2. #2
    Join Date
    Jun 2007
    There is a free version of xpadder which works (and included x360 profile), here is the link:

  3. #3
    Thank you for the link to the free version. Unfortunately when i tried to start the program it told me I don't have the correct OS. I have windows 8 and its meant for XP, Vista and 2007 I think it said.

    Also that did not answer my question of who I can contact to get this fixed in game, since I don't think that it was right that it was sold like that. I appreciate the help though.

  4. #4
    Join Date
    Jun 2007
    Oh, I see... sorry to hear it is not working - maybe try compatibility mode?

    And about it getting fixed - that just won´t happen, unfortunately. The best way to play SR1 is on ps1 or on dreamcast or PSN.

  5. #5
    Hi Thecaboose,

    can you please do the following.

    1. Right click on the the program Xpadder
    2. In the list click on properties
    3. Click on the compatibility tab
    4. Click on the box "Run this program in compatibility mode for"
    5. in the drop down menu, select "Windows XP service pack 2"
    6. Click apply and then ok.

    This worked for me.

  6. #6
    Join Date
    Feb 2015
    Thank you for the solution. I saw this game come up for sale, and was all about grabbing it as opposed to setting up my old console to play... then I discovered I couldn't use my controller!

    It's a shame they couldn't have taken a bit of time and provided proper controller support, since they keep cancelling sequels for this series.

  7. #7
    Is there a normal solution to this problem? I mean, without disable the gamepad in the game, and assigning keyboard keys on the gamepad?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts