Page 2 of 8 First First 123456 ... Last

Thread: Square Enix is aware of the game-save looping problem

Square Enix is aware of the game-save looping problem

  1. #26
    Join Date
    Mar 2014
    Posts
    38
    More than TWELVE hours have passed yet not a word of acknowledgement or anything of that sort from the developers?

    What kind of a service is this? DE HR vowed me, but I played it more than 2 years after release when all bugs were taken care of. Yet getting Thief so close to launch surely has me regretting.

    It is UNACCEPTABLE for a game of this stature to have game-breaking bugs.

    I am going to file a complaint with Steam to refund me my money in the event save files cannot be recovered. "AAA" games aren't cheap, that's for sure, and I expect some baseline quality from them.

    Do not cower in the dark, developers!

  2. #27

    Thumbs Down Stuck in Client Job

    I did the job "Hand Tailored" as soon as I could in the game. Completed it, and went on my way. Did another chapter, and accepted Ector's next job. Now, whenever I go to change areas just about anywhere (including the main mission and Ector's new mission) it takes me back to Alfonso's tailors and puts me back into the mission, automatically.

    I can't advance in the main story line, manual saves DO NOTHING, and it ALWAYS reverts back to the autosave, which seems to be stuck on this side job.

    I've tried restarting the game, I've tried completing the Hand Tailored job again (it just restarts after pressing "Continue")...I'm at my wits end. If I lose this save, it will be about 4 hours of work lost due to a simple save issue.

    TL,DR - Autosave won't update, permanently stuck in client job loop, no matter how many manual saves I revert to. When changing areas it loads back into the autosave.

  3. #28
    Join Date
    Mar 2014
    Posts
    38
    Nothing. Wait for Eidos to fix it, that's all.

    This is a game-breaking-class bug.

    It is an April fools joke gone bad, simply put!

  4. #29
    Join Date
    Mar 2014
    Posts
    38
    Game breaking bug, this is. Wait for a patch. Affects everyone globally on all platforms as of 12.00am April 1. April fools joke gone bad!

  5. #30
    Originally Posted by himmatsj
    Game breaking bug, this is. Wait for a patch. Affects everyone globally on all platforms as of 12.00am April 1. April fools joke gone bad!
    What?!

  6. #31
    That's funny...cause my autosave is stuck on March 31st at 23:56 (11:56)

    The crazy thing is, the autosave has actually updated! I've checked under the load menu...yet it still reverts when I try to load new areas in the city. I just don't get how/why it keeps teleporting me back to this mission I already completed hours ago.

  7. #32
    In a similar boat as I have a save fairly close to the point where you talk to the baron on chapter 6: A Man Apart and Thief has lost its effing mind on this one. It REFUSES to do any kind of save from that point forward (any attempted manual save is a save at the START of the effing chapter). Going up to the baron's door and opening it re-starts the effing chapter.

  8. #33
    Same here, only when I save, it gives the same time as my last save (from a few days ago) and starts the job I'm doing all over. I can't save at all essentially, and loading only takes me to the chapter start. Is this a confirmed bug and can it be fixed? Should I just wait for a patch and hope for the best? I'm on PC.

  9. #34
    Just posted on another message about a similar problem in chapter 6 (other post had it in chapter 7) where I am close to the point where I open the door to talk to the baron. Any attempted save after loading that last successful save is a save to the START of the chapter and opening the door to talk to the baron re-starts the entire chapter. They broke it BUT GOOD. Guess I don't get to enjoy the game I paid for till they un-eff it.

  10. #35
    This seriously better not be an April fools "joke". I am NOT AMUSED by being stuck.

  11. #36
    It seems to be fairly widespread across multiple platforms, although it seems to be affecting everyone at a slightly different place in the game.

    Most of the posts I've seen are about being stuck in a chapter loop, or the save reverts to the beginning of the chapter if they die, fail, etc.

    I'm just hoping it's a quick fix or fixable at all. I can easily see this being a save game corruption similar to the issues Battlefield 4 had. I haven't touched that campaign since I lost all my progress one mission from the end. I'm about to return this game.

    This is my second playthrough, and I've spent about 4 hours doing the collectibles and secret areas. I'm gonna be mighty pissed if I lose all that progress.

  12. #37
    Seems to be a recent bug hitting a LOT of players where instead of moving forward in the story line (multiple chapters and saved locations) it just re-starts a last point.

  13. #38
    Literally just hit the same bug that reset all my progress in chapter 4. Now whenever I try to go to the chapter 4 mission it loads up Ector's voice box mission instead. Do these guys not know what QA is or something? This is ridiculous.

  14. #39
    Yeah, I would imagine that it's hitting every platform and every player that is currently playing the game simultaneously. Terribly annoying and frustrating. If they don't fix this in a timely manner, I'm selling it and getting Blackflag. I heard it's better anyway.

  15. #40

    Xbox One - Looping in clock tower

    Yesterday i was really worried when my game started to loading loop the clock tower, but today im seeing a lot of people with the exact same problem so im more relaxed, hopefully they fix it soon.
    I just want to let them know this is not a single "freak" problem and many players (me included in 2 separate playthroughs) have they game broken. In my case i keep loading the clock tower every time i try to exit it to enter the stone market, the same issue in both of my saves, one master completed and the other in rogue with the chapter 6 just completed (and a looot of collectibles gathered)

    Edit: Whats wrong with this forum? i just registered for this only one message and it shows as i posted 999999 messages, not like i really care, but ... well, is just weird.

  16. #41
    Join Date
    Mar 2014
    Posts
    38
    Eidos is crumbling perhaps? April 1 causing a multitude of issues for them. On the forums, and within the game. Not LOL at all!

    Anyways, post in the other threads. I myself have the same issue. Continuous looping in the clocktower after Chapter 4.

  17. #42
    Originally Posted by Ilindur
    Edit: Whats wrong with this forum? i just registered for this only one message and it shows as i posted 999999 messages, not like i really care, but ... well, is just weird.
    The 999999 posts and everyone being displayed as Spammers is an April Fool joke I think (last year we were all Moderators), just ignore it. The broken saves is another matter though.

  18. #43

    Ector's mission keeps repeating

    I'm currently doing the last (?) mission for the engineer in the clockwork mansion and after i finished the sidequest and receive my stats, i press "continue" and the game just sends me back in there again to do the same thing over and over again.

    I first though i pressed the wrong button or something since there is an option to redo every mission, but after completing it a couple of times i can say that the game is looping.

    Pressing "go back into the city" in my main menu just cancelled that sidequest and keeps it open on the map even though i completed it a couple of times now.
    Luckely it isn't the largest or most difficult mission, but that damn heroglyph wall puzzle..



    And also, i noticed that the the load/save menu is busted. I (manualy) saved just before completing the mission and every save just brings me back right at the start of that mission.
    And it looks like there are different saves to 1 save slot for no apparent reason? When i save my game to save slot 1 for instance and if i press load save slot 1 there are 2 save's open for that slot..?
    I actually noticed that from the start of the game but there wasn't a moment when i needed to reload my game other then a quicksave/quickload for a difficult part so it didn't bugged me until now

  19. #44
    Oh, man. This game is a joke.

  20. #45

    FIX FOUND for Save issue for PC / Windows 7

    There is a fix for PC users if you have Windows 7. Adjust the date to April 2, and make sure to uncheck the sync with internet box in the third tab of the clock / date menu. This should allow you to continue. For others, try setting your time ahead to tomorrow and see if it helps. I have confirmed this works for Windows 7 at the very least.

    EDIT: It has been brought to my attention that this doesn't work for all Windows 7 users, so proceed with caution. If you want to try it though, the exact steps I took to correct the issue are as follows:

    1. Click on the Date / Time
    2. Click Change Date and Time Settings
    3. Change date to April 2
    4. Click Internet Time Tab
    5. Click Change Settings
    6. Uncheck the box there labeled "Synchronize with an Internet Time Server"
    7. Click Ok
    8. Load Save Game
    9. Wait a few seconds and try saving the game. It should now work.

    I had to make sure I had deleted all saves attempts in the IN GAME menu (that failed) from April 1 (which didn't say April 1, they just mirrored my prior save data). Once that was done, progressing a little and saving allowed me to continue on and the save registered properly (well, properly, as in saying "April 2", and the time).

    I hope that helps. As always, you should always backup files before trying anything.

    If I get any more information, I will update the OP, and this will include any platform. I'm not resting until it is either fixed or we hear it's being fixed in an official capacity.

  21. #46
    Very similar issue (a lot of people have run into this issue) for me too - both in Chapter 3 and Chapter 2. It doesn't matter which save I pick. It just keeps looping the same section of level over and over again.

    Very disappointing.

  22. #47
    I don't know if it will work, but there is a fix for PC. Try setting your clock / date ahead to April 2. This works for PC. Short of an actual update or waiting until tomorrow, this is the only known solution.

  23. #48
    Black Flag is awesome. Definitely get it. Better than this.

    Despite that - I really wanted to see what this re-imagining of Thief was like. It must be some bug that was written into their game. To hit everyone on the 1st of April just seems too coincidental.

  24. #49
    Originally Posted by TornPr1nc3
    I don't know if it will work, but there is a fix for PC. Try setting your clock / date ahead to April 2. This works for PC. Short of an actual update or waiting until tomorrow, this is the only known solution.
    Worth a try. Amazing if this is someone's stupid idea of an April Fool's joke.

    Thanks.

  25. #50
    You may also want to disconnect from the internet which can sync with the time / date automatically. It's a pain, but if it works for today, it is worth it.

Page 2 of 8 First First 123456 ... Last