Thread: Stuck in chapter 2

Stuck in chapter 2

  1. #1
    Join Date
    Mar 2014

    Stuck in chapter 2

    I am playing the game through with all the custom mods on and

  2. #2
    Join Date
    Mar 2014
    i have the same problem, in the pc version of the game. (build 4110.1)

  3. #3
    Same problem here, and obviously I can't come back in the city to do something else ... really disappointed about the jump system, I figure like I'm on a rail, not in a world! Please change it!

  4. #4


    I have the exact same problem. I am currently trying to validate the integrity of the game files, so ill let you know if that makes a difference. I really hope I don't have to reinstall

  5. #5
    Okay so I verified the cache and it said that there were 6 files which were messed up, so it downloaded the files but I'm still stuck behind the invisible wall :/ Has anyone tried reinstalling?

  6. #6
    I am also stuck in the vent on level 2. Is there any plan to address this problem?


  7. #7
    Currently reinstalling, I'll keep you guys posted on whether or not this fixes our little problem.


  8. #8
    I'm having this same problem as well.

  9. #9
    You have already inspected the window so that Garrett says he needs to find some other way in right?

  10. #10
    That is correct ^ At least in my case.

  11. #11
    Founded a possible solution, as they wrote here
    Originally Posted by NIB
    There is a dedicated "drop down" button on PC. I think it's "X" by default.
    This worked for me

  12. #12
    I don't know what did it but all of a sudden my character decided to appear on the other side (exit) of the vent on load instead of inside it, thus getting me unstuck. Strange. I'm not complaining though I guess, it allows me to continue playing through the game.

  13. #13


    Guys and Gals; I reinstalled the game and it fixed the problem. I was able to pass through the vent. SteamCloud saved my gamesaves so all you have to do is right click on Thief in the steam games library and select 'delete local content'. Then redownload and install the game and it should be fixed. Only problem is 20gb takes forever to download.

    Good luck guys!

  14. #14
    I also experienced this problem, too. Here is what I noticed:
    It only happens if I have the Reduced movement speed enabled. (At least that seems to be the cause.)
    I retried it with my first playtrough savegame where I had normal speed. I got out of the vent just fine.

    Then I tried it witth the second playtrough savegame, and I got stuck again.
    I am in my third 1050 custom point playtrough so it is a bit frustrating that if you leave the game you have to restart the chapter.

    It seems that there is a special position or special sequence of movement keys that can help pass trough but I was unable to tell what they are. Climbing back is easy. So easy that you will get stuck again if you try to climb in and the climb out.

    I might try to reinstall it, but this is definitely a game breaking bug, that should be dealt with in patch.

  15. #15
    I too had the problem, I confirm its to do with the slow movement Mod, I got round it by going backwards and kept turning with the mouse at the same time, it took a few seconds but eventually got through.

  16. #16
    Thanks for the tip.
    Yes going backward and doing a 180 seems to work. Much better than blind trying.
    I'll try to continue my 1050 point run then.

    EDIT: Of course it wasn't as smooth on the real run. I got trough after I started readying and putting away my bow.

  17. #17

    Please fix this broken game!!!!!!

    Still waiting for an xbox one fix...all I see and hear is for PC but the game seems incomplete across all platforms...

    When can I expect to be able to drop out of the vent on level 2?

    If you can't get your game to work, how about a refund?

    Don't like wasting my money...

  18. #18
    Seriously, Eidos Montreal! It is 1.5 version, and this bug is still present.

    Another workaround I found is to reset the Graphics settings to default. I play with 100 FOV on Low settings, but setting back to Normal with 90 FOV seems to get me out of the vent. I walk to the exit of the vent, open the Options menu and hit restore on the graphics settings. Once I'm out I change it back. Seems to be more consistent solution then fiddling with the movement direction and the bow.
    The solution (or better call it workaround) that seems to work consistently: I set the graphics settings to Very High. Of course I have to set it back once I am out of the vent, because the fps drops below 10, but at least it works.