Thread: FFVII Graphics Issues

FFVII Graphics Issues

  1. #51

    Im having the same problem too and i send a message to square enix and they told me that my graphic card cant run the game which is bull cause i have GT220 so it can run that game. they just need to update there stupid game cause im not really happy with them

  2. #52

    This fix worked for me. Thanks!

  3. #53
    I tried to play FF7 that I just downloaded and I get the message: " Failed to create a useful Direct3D device". How do I resolve this. I downloaded the latest Direct3D and the latest Winzip programs, and I still get this message. Thanks!

  4. #54

    Just an update: I am running an old Acer, probably from 05. It runs on Windows XP. I downloaded the latest; Winzip, Windows Media Player, DirectX, RDFx Voodoo 2. My only possible concern is that I am missing something within Winzip. I downloaded Voodoo 2, opened in winzip, a bunch of files appear. Do I need to do anything to "activate" or install any of these files? I feel like if I have all of the above programs downloaded, my FF7 should work, right? I even uninstalled FF7 and reinstalled it. I changed the the settings to a windowed paramater (non full screen), and tried all of the different resolutions. Still, same message: Failed to create useful direct 3d device. Someone has gotta know how to fix this, please help me out.

  5. #55

    Fix worked for updater, still getting 'Failed to create a useful Direct3D device.' error though..

  6. #56

    Same issue here, running Windows 7 via Parallels 8 on a Mac. Error occurs whether I'm running DirectX 9 or 10. Would love some help - thanks!

  7. #57

    You might want to check some of the related 3Dfx sites for perhaps a set of beta graphics card drivers or something which has been coded for that card in the last 7 years. I'd also recommend doing your Windows Updates as there may be a whole slew of items which may affect this, DirectX, .net, device drivers, etc. just to be sure. Whenever I've seen an issue like this on my systems it's been because I've had another program running (eating up resources), for which I would suggest doing a clean boot via the MSCONFIG tool. Or, I've seen this when running multiple monitors or an SLI/Crossfire scenario, for which I would have you check any attached displays/extra monitors. Basically disable all other displays, give the system a reboot and see if it frees up the video processor.

  8. #58
    Once I enter the world map and explore around a message pops up saying Error: An unknown exception has occured and crashes. Would I have to re-install the game in order to fix the problem?

  9. #59
    Join Date
    Mar 2008
    The Lifestream

    [Blackout / error as soon as I reach the world map...]

    Originally Posted by Miriam

    RESOLVED: Cleaned most traces off my computer and did a fresh install. At a guess, the problem was a corrupt WM0.BOT.

    [Graphics Problem - Left Midgar and its VERY dark]

    Originally Posted by Miriam

    We would like you to please Click on Start, and click on Run (or hold down the windows key and press "R". At the run line type in DXDIAG, and hit OK Click "Save all information" (in the Dxdiag window) and save it to a TXT file. Copy all that information and reply to this thread with it.

  10. #60

    Just an update it appears to be my graphics card. Square support emailed me saying I will be unable to play the game until I update my driver. I then did a search on drivers and got a bunch of spam ones. I downloaded from the graphics card manufacturers website directly, but when I tried to install it through winzip, nothing happened when I double clicked the setup.exe option. Its like no matter what I do in order to get this game to work, another challenge lies in my way each time. And honestly, I am getting really close to just giving up and getting a refund. Im scared to even get this game working because of all the problems people seem to be having and negative reviews. Anyways, I guess I am upset because I thought it would be an easy download and boom, I can play. Instead there are these specific requirements and hoops you have to jump through if your display is not exactly what the game dictates. And geez, why couldn't they make this compatible with mac? I wouldn't be here in the first place. I mean, I know I pulled my 7 year old computer out of the woodwork and all, but seriously, final fantasy 7 graphics on the playstation one which was released in 1997 is not compatible with my 2005 PC? Wow, not sure I understand the system requirements to demand a graphics card of a certain prestige in order to run a game from 97!? Hopefully someone reads this, because I can't be the only one who thinks that logic makes no sense whatsoever.

  11. #61

    Thanks for the thread links Gravity, those definitely cover the issue. A reinstall may be the simplest way to get this back up and running if it is some corruption issue. You can get the client once again from if you don't have the files anymore. Though double check that you can re-download them before deleting anything. If this is not related to the files you'll want to make sure that your DirectX and graphics card drivers are up to date. You can check out your card manufacturer's website, either or for these updates.

  12. #62
    I play this game on my home computer with no problems at all running Windows 7 64bit. I am having a problem when I was trying to run this on my computer I use in my business when I run the launcher the updater will fail it just says error can't start the updater it seems to download it ok. I am stuck on version 1.0.5 so I'm not sure if that is the cause of my second graphical problem. The graphical problem seems to be related when the game is displaying content that isn't a polygon everything that isn't a polygon will show up as black so when you start the game you just get a black screen I can start the game and it plays the opening FMV just fine but when you hop off the train the screen is black and you can only see Cloud and the guards.

  13. #63

    I am running windows 7 64bit version. The game will start up and the opening movie plays but after that when you get to the scene where they jump off the train, the background is just black but the characters appear and I can control them.

    Any one know how I can fix this? Also when I get into a battle, the background will show and the characters will but the menu doesn't show up and when I attack an enemy the damage numbers don't show up.

    Also I cannot get the updater to work (not sure if this is the source of my problem). I have tried most basic troubleshooting methods but cannot get it to work.

    Any help on this would be so greatly appreciated since email support has been absolutely abysmal in helping me


    This thread solved everything for me.

  14. #64

    I had given up on getting this working for quite some time. The other day I reinstalled and still have the same problems. I was hoping that there would have been some sort of solution by now, but sadly I have not found it.

  15. #65

    Alrighty, thank you for posting that you got this fixed. While the game wasn't designed for that type of system I'm glad to see that the response from this other thread got it going for you. I'll be sure to pass this along to others with a Black box graphics problem. Way to go, thanks again.

  16. #66

    My original problem above has been fixed. I have a new one now. Game runs fine and everything is going great except... the background graphics look horrible. I turned on my original PS1 copy to see if it was just me but the PS1 background graphics look better than this version. They are very choppy and not the least bit smooth.

    Ive tried a ton of different settings... just cant figure it out.

  17. #67


    I just installed the game and am finding the same issue with the updater not working, currently at v1.0.5. I don't however seem to have any graphical issues.

    James: Are you have trouble with any other games or just this one?



  18. #68

    I'm having the same graphical issues as James.

    All the menus and backgrounds are black, only Cloud and the other characters are visible.

  19. #69

    A pink pixel apears in a tree of the "Sleeping Forest".
    Flickering Cait Sith in temple.
    Red pixels inside room you obtain "Aurora Armlet".
    Red pixel in "Gast's House".
    Green pixels in multiple trees in"Great Glaicer".
    What other glitches can I look forword to?

  20. #70

    I having the same problem and just posted about this before finding this thread. It seems this has been an issue for a long time. XD

    Nobody enjoys only using a portion of their screen...this seems like something SE could patch to allow full screen during gameplay...I'd like to hear from a moderator if it's possible and if there are any such plans to do so.....please

  21. #71

    When you see letterboxing on your screen it may be because the game was intended for a different resolution monitor than the one it's being displayed on. Before booting up the game you may want to take a few steps to see if it can be first corrected. Please do make sure you've got the latest video card drivers and DirectX installed (we've even had people show positive results from installing Divx9) first. Then navigate to the settings menu area of the launcher and change the resolution settings to match your desktop area and format. Some monitors are at 16:9 and some are at TV formats like 16:10 so it may take a bit of tweaking. Sadly with a legacy title like this one letterboxing is an inevitability, we're always happy to pass along the Community feedback though. Thanks!

  22. #72

    The top part of the screen is cut off a bit and part of the bottom of the screen has some black on it is there anyway to fix this

    EDIT UPDATE: unless that is how its supposed to be cause when im in the menu for changeing members or adjusting materia. The whole menu is in screen.

  23. #73

    FFVII Graphic Issues

    Just bought FF7. Game plays great but the environment graphics are terrible. Ive troubleshot all the video settings and still looks awful. Th characters are nice and crisp but the environment is pixelated. My resolution is set to 1920 x 1080 and like I said, the characters reflect. Is this normal?

    Thanks in advance.

  24. #74

    Because is re release is the same version of 1997! PLaystation 1

  25. #75
    Originally Posted by silvergol
    Because is re release is the same version of 1997! PLaystation 1
    I had the original, and the graphics of the enviroment seemed much better..

Page 3 of 4 First First 1234 Last