After searching and trying everything we found a solution, worked for me and my friend was going into your router and changing the MTU value to 0 or auto configure and apply settings. The max value...