Thread: Updating The World Ends With You

Updating The World Ends With You

  1. #1

    Updating The World Ends With You

    Dear Square Enix,
    According to this thread, you are violating one of Apple's developer agreements regarding compatibility of iPhone apps being able to run on iPad OS, specifically regarding The World Ends With You. Given how sensitive you are to legal issues, it would be nice if you could be the pacesetter in this and remove the loop in code that currently forces customers who purchased the iPhone version of TWEWY to also buy the iPad version, instead of just allowing them to play the version they already purchased. All of your other games allow this --- except for TWEWY. From my understanding, the fix is quite simple and could be done in a very quick update, just rewriting one line of code in your .ipa file.

    I understand how the iPad versions cannot play on the iPhone because the software is coded differently, but the iPad was designed to function as both an engine for iPad software and an emulator for iPhone software.

  2. #2
    Not to trivialize your problem but Square enix are messing up so bad right now... this is the least of there issues.

  3. #3
    Regardless of how they are doing with their other games, they have a responsibility to maintain the ones they have already released. As much as I may agree with your sympathy for their plight, they are big enough to put their own pants on in the morning. Or at least ask someone who knows how to do it to teach them.